New error in inserting text in Daily Note

Hi , I have an error that has just recently cropped up in a shortcut that I created to insert text at a placeholder in my daily note using Actions for Obsidian. Up until recently it worked flawlessly. However, when I tried it today, I’m getting a dialog box asking what the file path is for the daily note. I have the daily note identified in the correct vault and so I’m in a loss.

As the shortcut runs, it correctly opens the most recent daily note (so it does “know” the correct file path relative to the vault). But my dictated text is never inserted at the placeholder and instead a dialog appears twisting the file path. The dialog box contains the following

What’s the file path of the note?
File Path (Get Most Recent Periodic Note)

Any help would be greatly appreciated!

  • I should add that I am running the iOS 18 beta

Hi @Joe_Girardot, welcome to the forum! It’s possible that you’ve run into an issue with iOS 18 beta, indeed, but unless I see the part of the workflow in question, I can’t tell for sure. Could you provide a screenshot, maybe?

Hi @czottmann ! Thanks for getting back to me.

I’ve attached a screenshot here. I’ve obscured the vault name but it’s the same in all three locations

Thanks. I don’t see anything out of the ordinary here. Do you use iCloud Sync by any chance? Because I’ve heard of notes temporarily “vanishing” for a sec or two because iCloud Sync decided it needed to sync that file right now, hiding it temporarily in the process, and actions trying to access it in the meantime did fail.

Side note: Your workflow is a bit needlessly complicated, however, and could be simplified, which might change the outcome.

My guess is you actually want the current daily note, and not just the most recent one, is that possible? (Because Get Most Recent Periodic Note and Get Periodic Note do slightly different things.) If it is the current daily note you’re after, you can use the Periodic Note versions of these actions:

With them you don’t have to juggle the reference to a particular note:

If the issue persists, it might indeed be a problem related to iOS 18 beta, as there haven’t been AFO updates since.

Carlo

Thanks for the review of my Shortcut and tips. However, it seems as if iOS 18 may be the culprit. For some reason the shortcut using the insert text action cannot locate placeholders, position the cursor relative to the placeholder and paste the text. As a result, even though the shortcut can open the Daily Note with no issue, it never pastes the dictated (or even typed) text in the desired location.

I was able to do a workaround using your Search and Replace action, however. That action, for some reason, can locate the placeholder. I simply have the shortcut locate the placeholder and replace it with the dictated text + add a new identical placeholder string at the end so that the next activation of the shortcut will have something to act on.

I’ve provided a screenshot below. This is not as elegant as your primary insert action but it gets the job done for now!

  • The regular (as opposed to dictated) text box is there solely to supply a line break to move the newly added placeholder to the next line

Thanks for getting back to me! Okay, that’s a bit wild. Out of curiosity, does it make a difference when the placeholder doesn’t contain leading and trailing spaces? I mean, if the placeholder is %%myplaceholder%% instead of %% myplaceholder %%.